Wednesday, 10 June 2015


The projector here is an M260X NEC, manufactured in 2011. This was purchased in 20013, and has failed. On switching on, it beeps, the lamp would come on for 1 or 2 seconds, status light flashes once green, followed by 9 cycle red blinking status LED. Looking up the manuals, this is known as a 'dynamic contrast' error. There will also be a clicking noise as the motor tries to find a grip or position of the shutter/iris. Upon failing it will blink red, 9 times each cycle.

Dynamic contrast is used by the projector to darken the scene, to get richer blacks, it's active in a few modes, and can be turned off under, MENU, PICTURE, DETAILED SETTINGS. 

This projector is out of warranty and has about to my calculation 2000~hrs on the lamp. (When I got it working it was actually only 1600hrs) I figured it was not worth sending in for repair. I was quoted $40 for the Iris assembly, and $120 for the workmanship, quoted to me by the NEC service center in Singapore.

First time documenting a tearing down a consumer electronic device for repair. (Original fix was suggested on Fixya - link below)
You will need a small Philips head (+) screw driver for most of the work.


Make sure you get all the screws, I also removed all the feet of the projector.
One of the housing screw hides in the air filter area.

TIP: Unscrew the lamp cover as well. It has a micro switch, therefore, you may get an error if the cover isn't place via sliding it back in. If the top cover is just closed, the micro switch won't activate, giving a ONE BLINK error. So the last step is to slide back the lamp housing cover.


Gently pry open the casing, I find that it gives way easily from the filter side of things.
Do not force it open with much speed. The top cover is attached to the main board via the wire that leads to the lens cover sensor!


 Disconnect the sensor wire from the mainboard and remove from the cable loop/retainer. (I found this easier than removing from the sensor board)

Tada, the main board of the NEC M260X

I had to dig around some diagrams to see where to access the assembly. The main Fixya did not have any description.

When I Googled, 24B17981 I found a page with the schematic of this projector series

source: http://mobilepro.ch/content/orders/NEC%20DISPLAY%20SOLUTIONS/pdf/MNNMFILTERSET.pdf

To access the Iris you need to remove the main board. I decided to hinge it forward, by disconnecting the:
- LCD ribbon cables
- A few of the smaller cables towards the rear of the projector




Once the cables are undone, there are two screws at the sides of the IO panel / rear connector / input panel, that needs to be unscrew. (picture only shows one) Undo BOTH the left and right side. The entire board and rear IO panel should then flip forward. 

Have something for the main board to sit on, I just used the top cover to rest the main board so as not to strain any wires.

Next step: Remove the LAMP assembly. WARNING: Be careful not to touch any part of the bulb! like any halogen/pressure lamp source oils from your fingers can cause uneven expansion of the very very very hot lamp and blow it up. $371 in my country. 

You should see this once the main board is gone, and lamp is gone. It's a metal shield - BARRIER (LAMP) PBC0 24H69851; remove the two screws and remove it. This is located right next to where the lamp used to be housed. 

Once removed you will be able to access the Iris unit [ IRIS UNIT (PBC0) 24B17981]

Here is the offending clicker on start up.

Okay the fix:
I just move the blades back and forth a few times. And blew on the REFLECTIVE OPTICAL SENSOR, which in the fixya the guy describes as an octo-coupler. That's all I did an mine was back up working (so far).

Things you can try, maybe lightly grease the gears, NOT GUNK IT. 
Clean the sensor with isopropyl alcohol (at your own risk, should be safe)

Now once done and angry about a $40 part failing an $800 machine. Assemble everything back reverse order. 

NOTE: unless you defeat the micro switches, you need to replace all the covers for it to fire up.


Don't forget this little connector. It dropped in side and I forgot about it. Without this it gives me FOUR cycle red LED flashes. CPU/FAN/PSU error.

Have fun guys! (:






Original solution:
http://www.fixya.com/support/t16086633-nec_np_m300x_dynamic_contrast_error

Sources:
http://yourbusiness.azcentral.com/troubleshoot-nec-projector-beeps-14419.html
https://www.manualowl.com/m/NEC/NP-M300X/Manual/155046?page=124
http://mobilepro.ch/content/orders/NEC%20DISPLAY%20SOLUTIONS/pdf/MNNMFILTERSET.pdf

Tags:
9 blink status light, NEC projector error, Projector error NEC M260X; M260XG; beep code NEC projector; error code NEC projector; NEC status light blinking; NEC projector; Iris error; iris; 24B17981; Projector tear down; disassembly; DIY; Projector disassemble; repair; step by step repair; NP-M230X; M230XA; M260X; M300X; M260W

30 comments:

  1. where I can buy the parts, I've lubricated and keeps failing

    ReplyDelete
    Replies
    1. Hi there. I'm not sure where you are from. In Singapore, the service center didn't say that you could buy from them directly. They did mention the shutter assembly is $40 singapore dollars, but I'm not sure if they will sell it to you.

      I have yet to come across the component list, so I wouldn't know which part is failing. The REFLECTIVE OPTICAL SENSOR should be quite simple to get from like a radioshack or something, there should be some numbers on the component to match it.

      Delete
    2. Remove the all steel blades and connected gears only and keep rest of component as it was. And reassembled and check

      Delete
  2. Same error code on a m350x your tutorial/fixing solution work perfect.
    Thank you

    ReplyDelete
  3. Same error code on a m350x your tutorial/fixing solution work perfect.
    Thank you

    ReplyDelete
  4. Hi, really appreciate this. I am about to attempt the same thing.
    Question I am a little confused the "blades back and forth a few times" is this the blades in the irs unit (shown on photos)? Am I trying to loosen them or something? Also you didn't replace any parts just blew on the sensor, right?
    Thanks heaps for this!

    ReplyDelete
    Replies
    1. Hi,

      Thanks that you found this useful.

      I basically open and closed the sliver/metallic blades a few times just to make sure they were not stuck in any way. It's like opening and closing a shutter.

      I didn't replace any parts. but blew on the sensor with some air or a squeeze blower just to get some dust out.

      Cleaning it with high quality isopropyl alcohol will help too I guess.

      Delete
    2. Thanks, have it open now. Found the blades and have them moving but cant for the life of me see the REFLECTIVE OPTICAL SENSOR, where is that little beast hiding?

      Delete
    3. It should be on the tiny PCB of the iris unit. The same assembly as the metal blades.

      You have to fully open or fully close to see the sensor. It's tiny and a little tab moves in sync with the blades to activate the sensor.

      http://4.bp.blogspot.com/-2STN2kaR7JI/VXjQiOr89yI/AAAAAAAACio/QoBBh1HG6g4/s1600/close%2Bup%2Biris.jpg

      Delete
    4. It should be on the tiny PCB of the iris unit. The same assembly as the metal blades.

      You have to fully open or fully close to see the sensor. It's tiny and a little tab moves in sync with the blades to activate the sensor.

      http://4.bp.blogspot.com/-2STN2kaR7JI/VXjQiOr89yI/AAAAAAAACio/QoBBh1HG6g4/s1600/close%2Bup%2Biris.jpg

      Delete
    5. Thank you SO much.
      After many tries in the end I had to lubricate the irs blades. So as a note to anyone else they might move ok but they need to move quite freely.
      Again I am very grateful you took the time to make this blog!

      Cheers,

      Delete
  5. I was quoted $40 for the Iris assembly, and $120 for the workmanship, quoted to me by the NEC service center in Singapore.projector installation toronto

    ReplyDelete
  6. Worked like a charm, I just dismantled the unit and gave the shutter doors some movement and lined with some grease. Put the unit together and now the projector works perfectly. Thanks for your tips :)

    ReplyDelete
  7. Yep! Worked for a P350W which is almost identical except for some of the screw locations. (Well worked once then I got 6 red status flashes which is a lamp error-fails to light. Turned it off and on again and so far so good.)
    The optical sensor is tiny. It's found next to the motor on the IRIS assembly under the half cog/gear that moves the blades.
    I agree with a previous comment that the blades should move freely. This one had quite a bit of resistance and moving them manually wasn't enough. I used silicon spray (but dabbed it on so as not to get anything on the sensor) on all the pivot points and gears.

    ReplyDelete
  8. This info was great, I was able to free the iris and projector worked fine, Thanks., The biggest obstacle I had was disconnecting the ribbons (looked online and finally found where it shows how to disconnect)

    ReplyDelete
  9. The problem is that the motor sticks, if you unscrew the motor on the Iris unit a little, the motor should be able to move freely. You should be able to move the two metal parts back and through freely without any resistance. You could also try adding grease or oil to the gears, this could help a little too. I found that the Iris unit is also not needed, the projector will function without it, but the sensor on the Iris unit does need to detect movement when the projector starts up. Hope this helps anyone reading - thanks, Jack.

    ReplyDelete
  10. hey, i just wanted to say thank you for this..
    it saved my projector :D

    ReplyDelete
  11. could someone tell me were the octo coupler ( sensor) is mines not picking up the iris movement

    ReplyDelete
  12. Perfect information - Thank you for the perfect description saved us a small fortune! I think it's dust blown via the lamp housing jammings the gear cogs. I removed the small motor and then placed the iris assembley in a ultra sonic bath with isopropol - you should have seen the amount or muck that came off such a small part. Refit and it's a quite as a mouse and works perfect! Thanks again for your post. NG

    ReplyDelete
  13. Hi, Sombody knows where to buy the IRIS UNIT (PBC0) 24B17981?? I am trying to find this part on the Web. Prefered in USA if that is possible. Thanks in advance

    ReplyDelete
  14. Thanks! Fixed the iris problem. I have a purple tint on the screen now. Anyone know how to fix it?

    ReplyDelete
  15. i cant seem to get the ribbon connectors off any hints?

    ReplyDelete
    Replies
    1. LIFT THE BLACK TABS AND BE CAREFUL NOT TO RIP THEM, I RIPPED MY BLUE ONES RIBBON ON MY £2000 P451W, FUMING!

      THESE HAVE A BAD BAD BAD DESIGN FAULT WHERE DUST GETS TRAPPED IN THE LENS AND IS IMPOSSIBLE TO GET OUT.

      Delete
  16. Very helpful post. How do I disable the iris, I read someone comment that it's not necessary

    ReplyDelete
  17. Thanks a lot. WD40 on the IRIS UNIT and my NEC M350X is now OK :)

    ReplyDelete
  18. How did you manage to get the 3 ribbon cables off of the main board?

    ReplyDelete
    Replies
    1. http://3.bp.blogspot.com/-TF2q-Jp8Wjc/VXjOOE_1FuI/AAAAAAAACh8/hZLrfeY3hd4/s1600/3%2BLCD%2Bribbon%2Bconnectors.jpg

      lift the black bar that's press the flat flex cable down

      Delete
    2. This is an example of how flat flex is held in
      https://www.youtube.com/watch?v=C9PwK9eGrCY

      Delete